top of page

TROUBLESHOOTING

Select your operating system (iOS or Android)

Apple logo selected.png
Android logo selected.png
  • I can't download the APK file

  • Make sure you're using Chrome for downloading the APK file and that you have enough free space

  • If you're getting error 403 on Dropbox that is because you are being redirected to the Dropbox app. To avoid that, long-tap on the APK download link and choose "Open in new tab in group"

  • I can't install the APK file, getting "Cannot open file" error

  • Make sure to install the APK from the Files app, not from the browser.

  • I can't install the APK file, getting "App was not installed" or "Package appears to be invalid" error

  • Before installing the FCC app, make sure to uninstall the official DJI app

  • Ensure you have at least 4GB of free space during installation

  • If you're still encountering issues, do a reboot of the phone after removing the official app

  • I can't install the APK file, getting "Package conflicts with an existing package" error

  • Before installing the FCC app, make sure to uninstall the official DJI app

  • If you're still encountering issues, do a reboot of the phone after removing the official app

  • Application crashes on startup or when trying to login with the drone-tweaks credentials

  • If you are on Android 14, please note not all phone models are currently supported on Android 14. If you have a different device to use in the meanwhile, you can do so and this won't impact your ability to change the device once for free during your one-year license.

  • If you are on Android 13, this problem is most likely caused by a recent Google Play update. To fix this, you will have to uninstall the Google Play update that caused this. To do that:

    • ​Install ADB on your computer (help for this)

    • Open a terminal window

    • Run command `adb shell pm uninstall com.google.android.art`

    • Reboot phone

  • Application starts but the "drone-tweaks login" window does not appear

  • If you are on Android 12 or 13 and you are no longer getting the "drone-tweaks login" window or the "FCC Mode Enabled" message at startup, it is most likely caused by your phone installing Google Play system update from July 1st 2022 or from August 1st 2023.

  • If you already installed the latest version and you're still not getting the "drone-tweaks login" window or the "FCC Mode Enabled" message, you will have to uninstall the Google Play update that caused this. To do that:

    • ​Install ADB on your computer (help for this)

    • Open a terminal window

    • Run command `adb shell pm uninstall com.google.android.art`

    • Reboot phone

  • I can't login, getting error "Too many devices"

  • You are allowed to change your device once for free during your one-year license. If you wish to move your license to a third device, you will have to get the Register Additional Device pack. Use the same email when purchasing and your account will be automatically upgraded to allow another device to login.

  • FCC mode is not enabled

  • You need to take the drone outside to acquire GPS signal before FCC mode will enable.

  • Make sure you understand how to identify FCC mode, it is different on iOS vs Android. For a quick explanation and sample images, check the “HOW DO I KNOW I'M IN FCC MODE?” area from the FAQ page

  • 5.8GhZ is not enabled

  • For the Fly app, you might have to fly the drone for a few minutes before 5.8Ghz will be enabled for the first time.

  • For the GO4 app, you will have to re-pair the controller to the drone, follow the simple steps in this video.

  • App icon is stuck on "Waiting..."

  • That is how the app looks during the download process, just wait for it to finish. If you think there might be a connection problem and want to restart the download, just tap the icon once and then wait for it to finish downloading.

  • When trying to run the app, I'm getting "Untrusted Enterprise Developer"

  • In order to be allowed to run the app, you will have to trust the developer certificate we used to sign it.
    To trust the developer certificate, go to Settings > General on the iOS device.
    Scroll down to Device Management or VPN & Device Management and navigate into it. Under the Enterprise App section, tap on the developer name and then tap the blue Trust button and accept the confirmation message.

  • When trying to run the app, I'm getting "Developer Mode Required"

  • Starting with iOS 16, a new mode has been added that must be enabled before being allowed to run apps installed outside the AppStore.
    To enable Developer Mode go to Settings > Privacy & Security on the iOS device. Scroll down to the Developer Mode list item and navigate into it. To toggle Developer mode, use the “Developer Mode” switch. Tap the switch to enable Developer Mode. After you do so, Settings presents an alert to warn you that Developer Mode reduces the security of your device. To continue enabling Developer Mode, tap the alert’s Restart button. After the device restarts and you unlock it, the device shows an alert confirming that you want to enable Developer Mode. To acknowledge the reduction in security protection in exchange for allowing other apps to execute, tap Turn On, and enter your device passcode when prompted.

  • When trying to run the app, I'm getting "App is no longer available"

  • We are using an Apple certificate to sign the app for you. That certificate lasts for approximately one year, once that certificate (and your license) expires, the app will not start anymore.

  • When this happens, you will need to purchase a new license.

  • I can't login, getting error "Too many devices"

  • You are allowed to change your device once for free during your one-year license. If you wish to move your license to a third device, you will have to get the Register Additional Device pack. Use the same email when purchasing and your account will be automatically upgraded to allow another device to login.

  • Unable to install the app, I'm getting "Integrity could not be verified"

  • This error usually means the app is not signed for your device.

  • This can happen if your license has expired and the Apple certificate used to sign your app is no longer valid.

  • Another possible explanation for this is that you are trying to install the app on a different device. To do that, you will need to sign the app for this new device. Your options are:

    • get the additional signing package OR

    • if you prefer to handle signing yourself for your new device, you can also use an external service to sign the app

  • Mavic Mini or Mini SE doesn't switch to FCC, I can still see 13 channels

If you are using the Mavic Mini 1 or Mini SE, please switch the app to standard mode:

  1. Perform all the normal initial setup and login with your Drone Tweaks credentials

  2. When getting the 'FCC Mode Enabled' message, tap 'Options'

  3. From the options presented, choose 'Standard Mode' and restart the app

  • 5.8GhZ is not enabled on GO4

  • You will have to re-pair the controller to the drone, follow the simple steps in this video.

bottom of page